hplip plugin.run file does not match its checksum. File may have been corrupted or altered

4 марта 2021 г. 7:07

Для установки драйвера для принтера HP в Linux достаточно ввести в терминале команды (принтер должен быть включён):

sudo apt-get install hplip-gui
sudo hp-setup -i

Ответив на несколько вопросов, вы установите драйвер. Но при установке может быть ошибка автоматического скачивания плагина, например, в моём случае на Linux Mint 20.1:

/home/vivazzi/.hplip/hplip-3.20.11-plugin.run file does not match its checksum. File may have been corrupted or altered

У меня принтер hp laserJet P1006, и в моём случае, как видим, не удаётся скачать файл hplip-3.20.11-plugin.run. В вашем случае может быть плагин с другим названием. Чтобы решить проблему с установкой драйвера HP на Linux, нужно сначала самостоятельно скачать требуемый плагин с официального сайта HP: https://developers.hp.com/hp-linux-imaging-and-printing/plugins

На данной странице поищите в списке свой плагин и перейдите по ссылке. Откроется вкладка с текстовым содержимым плагина, сохраните его куда-нибудь на компьютер (Ctrl + S).

Затем запустите из терминала команду:

sudo hp-setup

И в открывшейся программе указать путь загруженному плагину в поле Select and install an existing local copy of the plugin-file:

Готово! Теперь можете протестировать принтер, распечатав тестовую страницу.

Оцените статью

4 из 5 (всего 4 оценки)

captcha
Отмеченные звёздочкой поля ( * ) являются обязательными для заполнения.

Спасибо за ваш отзыв!

После нажатия кнопки "Отправить" ваше сообщение будет доставлено мне на почту.

Автор статьи

Артём Мальцев

Веб-разработчик, владеющий знаниями языка программирования Python, фреймворка Django, системы управления содержимым сайта Django CMS, платформы для создания интернет-магазина Django Shop и многих различных приложений, использующих эти технологии.

Права на использование материала, расположенного на этой странице https://vivazzi.pro/ru/it/hplip-pluginrun-file-does-not-match-its-checksum/:

Разрешается копировать материал с указанием её автора и ссылки на оригинал без использования параметра rel="nofollow" в теге <a>. Использование:

Автор статьи: Артём Мальцев
Ссылка на статью: <a href="https://vivazzi.pro/ru/it/hplip-pluginrun-file-does-not-match-its-checksum/">https://vivazzi.pro/ru/it/hplip-pluginrun-file-does-not-match-its-checksum/</a>

Больше: Правила использования сайта

Представляю вашему вниманию книгу, написанную моим близким другом Максимом Макуриным: Секреты эффективного управления ассортиментом.

Книга предназначается для широкого круга читателей и, по мнению автора, будет полезна специалистам отдела закупок и логистики, категорийным и финансовым менеджерам, менеджерам по продажам, аналитикам, руководителям и директорам, в компетенции которых принятие решений по управлению ассортиментом.

Комментарии: 10

Sam
Sam

11.04.2021 12:01 #

Спасибо, уважаемый! Очень помогли)

Ответить

Артём Мальцев
Артём Мальцев автор

12.04.2021 7:16 #

Рад, что информация оказалось полезной!

Ответить

zdanila@mail.ru
zdanila@mail.ru

23.09.2022 6:08 #

Добрый день, есть ли возможность полностью вычистить hplip? OS Debian11

Ответить

Артём Мальцев
Артём Мальцев автор

26.09.2022 5:23 #

Добрый день!
По идее да, как обычный пакет, например, командой apt remove hplip-gui, если я правильно понял вопрос

Ответить

Гость
Гость

27.09.2022 5:05 #

Спасибо большое, я попробую. А хвостов нигде не останется ?

Ответить

Артём Мальцев
Артём Мальцев автор

27.09.2022 8:42 #

Чтобы прямо всё сопутствующее удалить (конфиги, например), можно ещё воспользоваться apt purge hplip-gui. А затем apt autoremove, чтобы ещё удалить разные зависимости, которые требовались для hplip-gui
Может ещё какие-то команды есть, но я уже не знаю. Мне обычно хватает этих команд :)

Ответить

zdanila@mail.ru
zdanila@mail.ru

17.10.2022 4:14 #

Здравствуйте, наверно Вы были правы, нужно было обойтись двумя командами (apt purge hplip-gui, apt autoremove), но я через поиск PCManFM-Qt нашел еще несколько файлов с расширением *.hplip и удалил их. После чего я "потерял" локальную сеть и службу CUPS. Восстановил следующим образом:
1. Исправляем ошибку входа на локальные ресурсы командой. (взято с этого сайта https://obu4alka.ru/resheno-slaxos-ukazannyj-adres-ne-podderzhivaetsya.html
sudo apt install gvfs-backends
2. Восстанавливаем службу CUPS с этого сайта: https://wiki.debian.org/ru/SystemPrinting#A.2BBCMEQQRCBDAEPQQ.2BBDIEOgQw- (писать много)

Ответить

Артём Мальцев
Артём Мальцев автор

20.11.2022 6:52 #

Спасибо за этот кейс! Ссылку поправил (редактор иногда разделяет почему-то последний символ - надо это исправить)

Ответить

zdanila@mail.ru
zdanila@mail.ru

17.10.2022 13:33 #

Первая ссылка битая, по возможности исправьте https://obu4alka.ru/resheno-slaxos-ukazannyj-adres-ne-podderzhivaetsya.html

Ответить

Артём Мальцев
Артём Мальцев автор

20.11.2022 6:52 #

Ссылку поправил

Ответить

Вы можете оставить комментарий как незарегистрированный пользователь.

Но зарегистрировавшись, вы сможете:

  • получать оповещения об ответах
  • просматривать свои комментарии
  • иметь возможность использовать все функции разработанных сервисов

Для комментирования от своего имени войдите или зарегистрируйтесь на сайте Vuspace

Отправить

На данный момент нет специального поиска, поэтому я предлагаю воспользоваться обычной поисковой системой, например, Google, добавив "vivazzi" после своего запроса.

Попробуйте

Выберите валюту для отображения денежных единиц